Is it better to purchase JoomlaLMS right now or to wait till the newest version compatible with Joomla! CMS 3.x is released?
This question bothers many of our customers, that is why we decided to review the issue of updating older versions of Joomla! CMS and JoomlaLMS.
It is possible to give a short answer to the raised question – you don’t have to wait for the new release of JoomlaLMS.  The point is that the process of migration of JoomlaLMS to the newest versions of Joomla! CMS has been significantly simplified since the release of Joomla! CMS 2.5. So don’t keep waiting. Why waste your time? Start a new e-Learning project on Joomla! CMS 2.5 + JoomlaLMS. As soon as a new version of JoomlaLMS compatible with Joomla!CMS 3.x. is released you will be able to upgrade your CMS to version 3.0/ 3.1/ 3.5.

Which Joomla! CMS version out of three should be selected? Is it better to upgrade at once or wait?

Table 1 Joomla! CMS 3.x version releases

Joomla! CMS 3.x version Release date Description
Joomla! 3.0 September 27, 2012 Intermediate release, will be supported for 6-7 months after the release
Joomla! 3.1 March, 2013 Intermediate release, will be supported for 6-7 months after the release
Joomla! 3.5 September, 2013 Stable version, a long-term release

The answer is obvious (see Table 1) – it is better to wait for the stable Joomla! 3.5 version. New version of JoomlaLMS will be released closer to the stable Joomla! CMS release as well, JoomlaLMS developers are already working on it. New JoomlaLMS version isn’t likely to be released much earlier as new Joomla! 3.0 has significant changes in comparison with the previous version and a lot needs to be modified in the current source code of JoomlaLMS. But JoomlaLMS developers are endeavoring to make the system fully compatible as soon as possible.

It is recommended to migrate your site to a newer version of Joomla! CMS only if you are using one of the Joomla! CMS versions described in Table 2.

Table 2 Compatibility of Joomla! CMS 1.x versions and JoomlaLMS 1.2.5

Joomla! CMS 1.x version Version support end date Description Compatibility with JoomlaLMS 1.2.5
Joomla! 1.0 July 1, 2009 Migrate from this version to Joomla! 2.5 as soon as possible. -
Joomla! 1.5 April, 2012 Security updates for Joomla! 1.5 have been stopped since the end of support for this version. Thus new security issues will remain unsolved. There is no opportunity for direct update from Joomla! 1.5 to Joomla! 3.x. The sooner you migrate to Joomla! 2.5, the better. +
Joomla! 1.6 August 19, 2011 It is recommended to upgrade to Joomla! 2.5 at once, not to Joomla! 1.7, as the latest version has a much higher security level. +
Joomla! 1.7 February 24, 2012 It is recommended to upgrade from this version to Joomla! 2.5 before the support end. +

We can easily provide some arguments for this recommendation, let’s review several conditions for it:

  • -If you use Joomla! CMS 1.5, you can continue using this CMS version further. But you need to consider the fact that this version isn’t supported anymore and thus new modules, plugins and components won’t be compatible with it. Several new features that were added in the latest version of Joomla! CMS will also be unavailable. And you need to be ready for security breaches which can lead to your resource hacking and loss of data.

    We recommend migrating your resource from this version to the latest stable Joomla! CMS 2.5. It is also an option to migrate to the latest  Joomla! CMS 3.0.

  • -If your resource is a combination of Joomla! CMS 2.5 and JoomlaLMS, then as mentioned above it is better to wait for the new stable release of Joomla 3.5. Joomla! CMS 2.5 will be supported for at least a year longer.
  • -If you only plan to start a new e-Learning-project it is reasonable to do it on Joomla! CMS 2.5, as at the moment this is the most stable and secure version which is fully compatible with the latest version of JoomlaLMS. The upgrade of this version to the newer ones will be a rather simple process as the Joomla team (Joomla's Production Leadership Team - PLT) suggested. It is possible to update the system to Joomla! CMS 3.0 via the Joomla update manager.
  • -If  you found new features in Joomla! CMS 3.0 that are crucial for your project and which you would like to start using at once it is also possible. You just need to base the whole website on Joomla! CMS 3.0, and the e-Learning  portal using Joomla! CMS 2.5 + JoomlaLMS.  If you select Joomla! CMS 3.0, you will need to update your resource every time a new version is released (3.1, 3.2) till the stable Joomla! CMS  version 3.5 is released.  It may also be necessary to update certain extensions to ensure their stable work with Joomla! CMS  3.х

 

It is possible to sum up the above-mentioned as follows:

No matter which Joomla! CMS version is used on your website it is recommended to update it to the latest stable version with long-term technical support.

We can also provide a piece of advice taking into account the above-said:

Before updating the system create a back-up of your website and database. Thus you will secure the resource and if necessary will be able to roll back the changes. Also it is better to wait for the stable long-term supported Joomla! CMS  3.5 with us. It will be necessary to roll back the changes is most of the modules, components and plugins used on your website aren’t compatible with new Joomla! CMS 3.0 yet.
It is also useful to transfer a copy of the site to the local server, update all the functionality and test the updated site thoroughly. Thus you won’t impede the work of your resource and will be able to decide whether it is feasible to update the live site at the moment as well.