JoomlaLMS 1.3.3 was released on May 30, 2014; this release addresses Joomla 3.3.x compatibility issues and requires PHP 5.3.x – PHP 5.5.x in order to operate.
Our software is still compatible with the old major versions of Joomla CMS: Joomla 1.5.x series and Joomla 2.5.x series. Also for those who still use old versions of PHP, there is a 'legacy' release JoomlaLMS 1.3.1 which can run on older PHP5 versions. The following table provides an overview of the JoomlaLMS system requirements:

Joomla/PHP PHP 5.0.x – 5.1.x PHP 5.2.x PHP 5.3.x - 5.5.x
Joomla CMS 1.5.x 1.3.1 1.3.1 1.3.3
Joomla CMS 2.5.x - 1.3.1 1.3.3
Joomla CMS 3.x - - 1.3.3

Please note that Ioncube loader version should also be taken into consideration to select the correct version 1.3.1 or 1.3.3 for your upgrade. JoomlaLMS 1.3.3 requires Ioncube loader version >= 4.4. If you have an older version of Ioncube loader but it is >=4.0, you can use JoomlaLMS 1.3.1. Our system won’t work if Ioncube loader version is older than 4.0. You can use joomlalms_helper.php in order to define the Ioncube version you currently have on your website.

In order to speed up our development processes we will not maintain compatibility with old versions of Joomla!/PHP in future JoomlaLMS versions. The newly released JoomlaLMS 1.3.3 is not compatible with PHP versions below 5.3.x, and with the next release (JoomlaLMS 1.3.4) we will stop maintaining compatibility with old versions of Joomla!. We are planning to make it Joomla! 3.x compatible only.

Stable version of Joomla! CMS 3.4 is going to be released on July, 15 or later. JoomlaLMS 1.3.4 will be available in July-August 2014.

This article was last updated on June, 04 2014.


Best Regards,
The JoomlaLMS development team